Copter will nicht richtig Fliegen (Holybro Pixhawk)

  • Hallo ich hoffe hier kann mir jemand helfen.ich bekomme den copter nicht zum fliegen.ich habe pixhawk verbaut.alles klappt soweit.Er hebt bei ca.40% gasstellung ab aber dann gehst los er steigt dann hoch wenn ich dann vesuche Gas weg zunehmen sackt er durch dann muss ich wieder Vollgas geben um ein Absturz zu verhindern.Ein Landung ist nicht ohne Beschädigung möglich

  • Hallo, selbstverständlich können wir helfen.

    Bevor aber an den Einstellungen der Fehler gesucht wird (klingt verdächtig stark nach meinen Erfahrungen mit der automatischen Schwebegasermittlung), würde mich dein Kopter interessieren: Motoren, Propeller, Akkuspannung, Abfluggewicht, Pixhawk typ.

    Wenn vorhanden ein Logfile von der SD Karte vom letzten Amokflug .


    Der Fehler klingt seltsam und der Schwebegasfehler tritt nur bei extremen auf zb. an einem übermotorisierten Kopter der so leicht ist, das er die ganze zeit mit 20% fliegt und dan plötzlich voll beladen abheben soll.

    Von daher müssen im Vorfeld Hardware inkompatibilitäten ausgeschlossen werden, wo zu es allgemeine Informationen über den Kopter braucht.


    Ich gehe davon aus das das seltsame verhalten im Stabilize modus passiert.

  • Hallo ich hoffe hier kann mir jemand helfen.ich bekomme den copter nicht zum fliegen.ich habe pixhawk verbaut.alles klappt soweit.Er hebt bei ca.40% gasstellung ab aber dann gehst los er steigt dann hoch wenn ich dann vesuche Gas weg zunehmen sackt er durch dann muss ich wieder Vollgas geben um ein Absturz zu verhindern.Ein Landung ist nicht ohne Beschädigung möglich

    Sind die ESC's richtig Kalibriert?


    EDIT: Logfile wäre wirklich hilfreich

  • Von den Daten her ist der Copter nicht zu über Motorisiert (ist doch ein 4x?), das Logfile wäre hier wirklich hilfreich. Ob Du die ESC's mit ohne ohne Pix Kalibriert ist eigentlich egal, die gleiche Funke sollte es aber gewesen sein.

    MfG: Thomas Drohnen-Forum.eu


    Meine Freundin würde ich auch gerne mit einer LBT Firmware flashen^^...


  • das müssten so um die 700g schub pro Achse sein, mit 1,4 Kg abfluggewicht ist er richtig Motorisiert. Flugzeit so um 12 min.


    Um die automatische Schwebegasermittlung auszuschalten wird der Parameter MOT_HOVER_LEARN auf 0 gesetzt. Poste bitte vorher was als Parameter MOT_THST_EXPO und MOT_THST_HOVER bei dir steht.


    Bitte noch nichts verstellen, ohne Logfile ist das Glaskugel lesen. Im Normalfall muss nur der Wizzard durchlaufen werden und er fliegt. Die PID Werte sind dann noch feintuning. Es kann auch hilfreich sein eine Rover oder Flugzeugfirmware aufzuspielen und anschließend wieder die Kopter Firmware, damit ist alles resettet (nur kopterfirmware aufzuspielen reicht nicht) und im Anschluss noch einmal der Wizzard.

  • Hallo Achim,


    also an den Parametern ist soweit alles in Ordnung, die Auswertung deiner Logs läuft noch, nach einem kurzen überflug der Daten geht der Verdacht in Richting zu starker Vibrationen. Ist aber noch nicht sicher. Wie schon gesagt die Auswertung läuft noch.

  • Er hat 25 A Schwebestrom und 70 A Vollgasstrom, das ist natürlich schon einiges.

    Viel Zuladung verkraftet er nicht mehr.

    Ich denke er hat so ein F450 Chinaclone mit 2212 Motoren oder ähnlichem, Für seinen Kopter sind die ermittelten Werte in Ordnung. Mein China F550 Hexa hatte ähnliche werte.

  • Wenn ich mir den Vergleich RC3 Eingang und die Höhe anschaue würde ich MOT_THST_HOVER weiter nach unten setzen, (0,35*thumbmed*). und die Automatische Ermittlung MOT_HOVER_LEARN auf aus (0).

    Das testen was dann passiert?(...


    MfG: Thomas Drohnen-Forum.eu


    Meine Freundin würde ich auch gerne mit einer LBT Firmware flashen^^...


  • Mann kann das Adrenalin beim Auswerten spüren.

    Der Motor nummer 2 (hinten links) tanzt ein wenig aus der Reihe wenn die Gewichtsbalance stimmt dann ist er nicht richtig kalibriert (ist aber nicht das Problem).

    Der Kompass wird ein bischen beeinflusst, dagegen hilft eine Motor/Kompass kalibrierung.

    Was noch komisch aussieht, sind die Steuerbefehle der Fernbedienung das sieht recht "digital aus" ohne feingefühl und wenn ich Gaskanal und Motorausgang überlagere könnte man meinen das war vom Steuerer so gewollt.

    Am Kanalmonotor würde ich überprüfen ob das Signal der Fernbedienung linear verläuft und wenn ja, muss MOT_HOVER_LEARN auf 0 und das MOT_THST_EXPO doch auf 0.5 probehalber reduziert werden und bei Verbesserung weiter runter bis zum wohlfühlwert.


    Fakt ist aber, der Pixhawk schaltet immer zwischen den IMU hin und her weil er aus den Daten keine vernünftige Lage berechnen kann, was auf ein Vibrationsproblem hindeutet.


    Ein Foto vom Kopter und der Befestigung der Pixhawk könnte aufschluss geben.

    Das ganze ist vermutlich eine Kombination mehrer kleiner Probleme.


    Inzwischen hat auch Thomas mit einem guten Ansatz geantwortet

  • Also ein Pixhawk 4 ist das nicht sondern ein Holybro Pix32;).

    Was hier aber auf jeden Fall falsch ist, ist die Ausrichtung des GPS Systems, da ist irgendwo ein Pfeil oben drauf, der muss in die gleiche Richtung stehen wie der auf dem Pix32.

    (Danach wir eine erneute Kompass Kalibration notwendig)

    MfG: Thomas Drohnen-Forum.eu


    Meine Freundin würde ich auch gerne mit einer LBT Firmware flashen^^...


  • Hallo Achim,

    hier die Propellerorientation für deinen "V-Tail quad":

    http://ardupilot.org/copter/do…nect-escs-and-motors.html


    Edit nach hinweis vom Thomas:

    Propeller 2 und Propeller 3 müssen miteinander Vertauscht und die drehrichtumg der Motoren entsprechend umgekehrt werden.


    Damit sind die EKF Fehler erklärt.


    Beim Kompass/GPS musst du nach draußen gehen und sehen ob die Ausrichting vom Kopter mit der Landkarte im Missionplanner übereinstimmt.

    Prinzipiell stimmt deine Ausrichtung nicht, aber bei Billig GPS/Kompass Modulen kann es sein, das vorne 12:00 Uhr erst vorne ist, wenn der Pfeil (der eigentlich vorne bedeuten soll) auf 04:30 Uhr steht. Es gibt verschiedene Gehäusebauformen und verschiedene Platinen Layout's und dem Ramsch Chinesen ist das völlig egal ob das funktioniert oder nicht, er baut zusammen was er in der Scheune findet und schickt es per Luftfracht direkt zu Ebay. Bei Original Holybro zubehör passiert sowas natürlich nicht.(Das heraus zu finden hat mich einige Haare gekostet)


    Gehe aber zu erst davon aus das der Pfei auch vorne bedeutet, richte neu aus und kalibriere neu. Wenn der Pfeil nicht stimmen sollte, schlägt auch die Kalibrierung fehl.


    In dem Fall würde ich erst die Baumängel beseitigen, bevor es an die Einstellungen geht. Der Kopter wird schon bald einwandfrei fliegen.

  • ?(Eigentlich müssen nur die Propeller auf der linken Seite getauscht werden, der schwarze vorne nach hinten und der rote von hinten nach vorn (aber herumgedreht).

    Bei dem hinten rechts erkenne ich keinen Fehler, der Motor steht ja auf dem Kopf, von dem her soll der Propeller sicher so montiert sein (das er dann nach unten bläst).

    MfG: Thomas Drohnen-Forum.eu


    Meine Freundin würde ich auch gerne mit einer LBT Firmware flashen^^...


  • Stimmt, ich habe mir die Bilder nicht richrig angesehen. Nur Propeller 2 und 3 müssen miteinander getauscht und die Drehrichtung der Motoren angepasst werden.


    Wenn sie verkehrt herum montiert gewesen wären, hätte man das im Logfile sehr deutlich gesehen und der Kopter mit seinen 1,4 Kg wäre vermutlich garnicht abgehoben.


    4 Augen sehen einfach mehr.

  • Danke ich prüfe das mit den Propeller an den Bilder dürfte ihr euch nicht halten waren nur für Foto auf gesteckt .pixhawk 4 ist das nicht ,gibt eine Unterscheidung zu meinem .ich habe noch einen anderen gps Pilz vielleicht sollte ich diesen nehmen